Etterna not taking inputs on Mac

(Notes: macOS Big Sur 11.2.3, and school laptop)

Etterna launches fine, until the popup that says “install some packs!” blocks me from getting any further. It doesn’t seem to be responding to any of my inputs. Tried the arrow keys, clicking, literally every key on my keyboard, etc. Nothing’s working. It might be because it needs global input monitoring?

So yea if it’s because of this, then I can’t play Etterna on this computer. If there’s some way to still have it register inputs, then I can. Either way, thanks for the help. Sorry that I’m another stupid macOS user asking a dumb question.

UPDATE: This question has been partially solved by just downloading the windows version and using wine, but if there’s a fix to the native mac version that would be much appreciated <3

1 Like

Identical issue. Thanks for getting ahead of me and posting. I’ve already given Etterna permission to take global inputs, but it still asks me to open system preferences to enable them on launch. Funny extra detail is that resizing the window by dragging the corner to be bigger than a certain resolution = instant crash. macOS Monterey 12.0 + m1 chip.

1 Like

I had the same issue, Mac is such a pain for installing rhythm games for some reason. Here’s how I was able to solve it. I noticed that when mac was asking for permissions for input and it took me to the permissions, that the Etterna it had in the permissions had the icon of the entire Etterna file and not the specific launcher I use to start the game, once I changed it the the launcher application it was able to take my inputs. Hope this helps


Exact same issue over here. Still asks me for my preferences even though I verified them over and over, and every time I open it there’s a popup saying it can’t open because it’s an unidentified developer but then it opens anyway. There was a single time I opened it where it said that crashpad couldn’t be opened because it was an unidentified developer, so I opeed it and closed that and etterna and tried to reopen it but that didn’t fix anything either. looked on other posts and downloaded OpenSSL using brew like it told me but it didn’t fix anything. I really don’t want to download wine since last time I did nothing happened. I’ll try that if there’s no hope left but I’d really appreciate if they updated it so it’s not an issue. I’m using version 11.6 BigSur.

1 Like

So I tried out what @transfiguration said to do and it opened the terminal and I saw errors with missing files and file locations. I’ll list them here.

  • Reading ‘Data/Defaults.ini’ failed: No such file or directory
  • Reading ‘Data/Static.ini’ failed: No such file or directory
  • Could not create ettp connection because: Connection creation attempt failed
  • Paletted textures disabled: GL_EXT_paletted_texture missing.
  • Failed to open the interface. - (iokit/common) not permitted(-1ffffd1e,738)
  • Core::Platform::boostPriority not implemented
  • Core::Platform::unboostPriority not implemented

I’m guessing that maybe the developers forgot to add these files and maybe tweak some privacy settings. If there is any way to get these missing files however, I’ll post under this comment

1 Like

Ok I don’t know what I did I was just relaunching it again but it worked. Only change made was to let terminal have access to my keyboard in privacy settings, not just etterna

1 Like

All of the mentioned log “errors” are non issues

The one mentioning iokit is indicative of an input permission or input api issue